Getting Started with Access

Computerized databases are a convenient system for storing, retrieving, analyzing, querying, and printing data.  Databases efficiently and accurately organize large amounts of information.  Access databases consist of different objects; tables, queries, forms, reports, pages, macros, and modules.  Access objects work in unison to store, input, search, and report the data, and to automate program tasks.  

Copying and Renaming a Database File

Creating a copy of an Access file is different than creating a copy of a Word or Excel file.  In Word or Excel you can create a copy of a file by opening the file in the appropriate application and saving the file with a new name (Save As).  In Access the Save and Save As commands save only the active object, not the entire database.  

You can create a new copy of an Access database by first right-clicking the file icon and choosing copy, then right-clicking in the location where you want to paste the copy (typically on the desktop, in a dialog window, or in a Windows Explorer or My Computer window), and choosing paste.

Opening and Examining a Database 

When you start Access you have the option of either opening an existing database or creating a new database.  

· Download the Access AC0101.mdb student data file by saving to the desktop.  Right-click on the file icon and select Properties.  Make certain that the Read-only attribute is not checked.  If it is, uncheck it.

· Open the Access AC0101.mdb student data file.  Access objects are viewed in the Database window (the window that opens when the database is opened).  When you select an object button in the left pane of the Database window, the right pane presents commands to create new objects and available objects of the selected type.

· You can maximize, minimize, or restore the Database window.  Try these options.  What happens when you minimize?  Compare restoring using the title bar of the collapsed window with restoring using the task bar icon.  

· Restore the window to a small size, while still seeing all the window contents.
· Click on the Tables object button in the Database window.  Double-click the tblPersonnel table icon.  The table opens, displaying the records in rows (personnel) and the fields in columns (information about each person).  An Access table is similar to an Excel worksheet.  What is the most obvious difference, besides the row and column labels?  Click the close button to return to the Database window. 
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· Click on the Queries object button in the Database window.  Queries are used to sort, to search, and to limit to just the data fitting specified criteria.  Click the QryCommission query button and then click the Open button.  This query displays the first and last name fields of personnel receiving commissions.

· Resize the query window by dragging the lower right corner when the direction arrow appears.  

· Reposition the window by clicking and dragging the title bar.  Move it off to one side so you can view the Database window at the same time.  Note that both the Database window button and the Query window button are available in the task bar.  

(Insert graphic of taskbar, including Start button as reference.)

· Click on the Forms object button in the Database window.  Open the frmPersonnelListing form.  Forms are used to input data and to view records one record at a time.  Note the title of the form window.  Forms actually display the contents of a table.  Size and move the Form window so you also see the Database window.

· Right-click in an open area of the form window and select Datasheet View.

· In the Database window, select Tables in the Objects pane and open the tblPersonnel table.

· Resize both windows to show only the first few fields.  Compare the two windows.  This illustrates that a form is based on a table.  What is the difference in the title bars?

· Click the Reports object button in the Database window.  Reports are used to summarize information for printing and data presentation.  Open the rptCommission report.  This report is based on the QryCommission query.

These four objects, tables, queries, forms, and reports, will be the focus of your assignments, exercises, and quiz.  We will work with each object in further detail below.

Examining and Using an Access Database Table

Tables are the foundation of the database.  Tables store all the data in a database.  A database can have multiple tables.  Tables consist of records, groupings of information about a single entity, be that a person, a business transaction, or an object.  Each category of information in a record, such as a customer’s last name, is termed a field.  In a table, records are displayed in rows, while fields are displayed in columns. 

· Open the tblPersonnel table.  When tables are opened they are displayed in Datasheet view.  This view is similar to a worksheet in Excel, except in Access some different elements appear on the screen – field name captions appear as column headings, and the rows (records) are not numbered.  The small squares, in the left-most column—left of the field columns, are record selectors.  

Each object in Access has both a Design view and Datasheet view.  In Design View, the elements of the view – field names and properties – are visible and editable.  Data types inform how the computer interprets data, e.g., as a number, as text, or as a date.  The Input mask is a field property designed to guide the user when entering data.  The input mask can be used for fields requiring special formatting such as parentheses, dashes, and other special characters (e.g., a phone number, a date, etc.).

· Right-click the Table window title bar, or below the records, to display the shortcut context menu.  Select the Table Design command.  This command changes the table to Design view, which allows you to modify the table.  Size the window to display all the fields. 

· Notice the changes in the General tab when you select a field.  Click the record selector for the PostalCode field.  Change the PostalCode field name to Zip.  With the Zip field still selected, change the Caption to Zip Code. 

(Insert illustration with changes.)

· Right-click the title bar and select the Datasheet View command.  What happens?  Yes, you need to save the change.  This saves the Table object only.  Scroll as needed to observe your edit in the field headings of the table.

· There are several other methods of changing views.  If the toolbar in the Database Window is visible, you can click the Design Button to change to Design view.  There is also a View toggle button in the Database toolbar, with a drop down menu.  Use the button to toggle the views.  Notice how the button changes according to the current view, offering the opposite view.  Return to Design view.  

(Insert graphic of the entire Database toolbar, with all buttons and with the View drop-down menu.

Access provides, in the bottom left corner of the table datasheet, navigation buttons.  The Navigation/Scroll bar also displays the number of the current selected record.

· Use the navigation arrows to move forward and back one or two records, and to move to the first and last records.

· Move to a different record by clicking in the record number text box, typing the desired record number, and pressing the enter key. 

· Select the New Record button.  There are two New Record buttons; one is the far right navigation button with an asterisk, the other is part of the Database toolbar.  The first field in record seven is the current selection.  This is an AutoNumber field.  The program will automatically supply the cell contents with a unique number.

· Tab to move to the next field in the new record.  Type in your first name.  Tab again and enter your last name.  Okay, you are hired now.

Access is different than Word and Excel in how information and changes are made.  When records are added to a table or records are modified, the changes to these records are saved as soon as you move off the record.  You do not have to explicitly save a record.  Tables are updated when you close and reopen them.

You can select and delete a record using the Delete key on the keyboard or the Delete Record button on the Database toolbar.  

· Move the mouse pointer over the record selector to the left of record seven.  The mouse pointer will change to a right arrow.  Click the selector square to select the row.  The entire row will highlight.  Press the delete key.  A warning dialog box appears to make certain you wish to delete, since the action cannot be undone.  Click the yes button.  Okay, now you’re fired.
(Illustrate the dialog box here.)

Toolbars work differently in Access than in other Office applications.  Many more toolbars are available in Word and Excel than in Access.  In Access the standard Database toolbar changes buttons according to the object selected, as well as the object view selection.

· Select View > Toolbars from the Access menu bar.  Make certain that the Database toolbar is visible.

· Click the drop-down menu at the right end of the Database toolbar, select Add or Remove Buttons > Database and make certain that all buttons show.  Add any buttons not showing.
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· Take careful notice of which buttons are displayed.  Now change the table view from Datasheet view to Design view.  Compare the toolbar buttons.  
· Again, use the toolbar drop-down menu to add any buttons not displayed.
Printing a Table.   It is always a good idea to view a table from the Print Preview screen before printing.
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· Make certain that the table is in Datasheet view.  Then click the Print Preview button in the Database toolbar.  Again, notice how the toolbar changes and make certain that all the buttons are displayed.

(Illustrate the Print Preview toolbar.)

· Maximize the Print Preview window.

· Click the Setup button in the toolbar.  

· Select the Page tab and change the page orientation to Landscape.

· Select the Margins tab and change the left and right margins to 0.75 (inches).

· What change occurs when you select or deselect the Print Headings checkbox?

· Click the Two Pages button.  Then click the One Page button.  Then click Close.
Using Forms

Forms provide a structured environment for maintaining data.  Using forms, you can accomplish different tasks; adding records, updating records, and finding records, tasks you can also do in the Datasheet view of a tables.  Forms provide a convenient means of viewing and editing individual records.  Forms also provide the same record navigation buttons as the table datasheet, in the lower-left corner.

Forms are a means of viewing data in a table.  Tables are the foundation of a database, the location where information is stored.  Modifying a record in a form illustrates this clearly.

· Open the frmPersonnelListing form object.  To add a new record this time, select from the menu bar Insert > New Record.  What are the shortcut keys to add a new record?  If you forgot to check, look again.  Add your first and last name to the new record.

· Close the form and open the tblPersonnel object.  Does your name appear in the table after you added it in a form?  If so, you’re rehired.  (Tables are updated when you close and reopen them, so if the table window was left open, you need to close and reopen to view the changes.)

Form view is also a very convenient way of printing records, individually or in series.

· Reopen your form object.  Then choose Print Preview from the File menu.  Notice how the records will print.  Close the Print Preview window.

To print only one record, select the record you want to print, then select File > Print.  In the Print dialog box, check the Selected Record(s) radio button in the Print Range dialo (Illustrate the Print Preview toolbar.)

· Maximize the Print Preview window.

· Click the Setup button in the toolbar.  

· Select the Page tab and change the page orientation to Landscape.

· Select the Margins tab and change the left and right margins to 0.75 (inches).

· What change occurs when you select or deselect the Print Headings checkbox?

· Click the Two Pages button.  Then click the One Page button.
Viewing and Publishing a Report

Report are typically used for presentation of database information.  Reports provide a tool for printing and displaying multiple records.  Reports can be based on tables or queries and can be as simple as a list of records, or can consist of groups of select records.  You can navigate through the various pages of a report in Layout Preview view using the navigation bar in the lower-right corner of the window.  

· Return to the Database window and select the Report Objects.  Open and view the rptHire report.  

· Move the mouse pointer over the report.  Notice that a tool icon replaces the standard pointer symbol.  Click on the report to zoom in and out of sections of the report.   Does the position of the pointer impact which section of the report you see?

· Using the Zoom box in the Print Preview toolbar, return to the Fit display.  Then change the display to 100%, again using the zoom box.  How does this modification impact the scroll bars?

Reports can easily be converted to Word documents.  When in Layout Preview view of a report, the Print Preview toolbar includes an OfficeLinks button.  This button also has a drop-down menu offering publish options.  The most recently selected option will display on the button.  As usual in Office, you can simply click the button if the option you wish to select is displayed.  If not, you need to use the drop-down menu to select your command.

· Click the Toolbar Options drop-down menu at the far right end of the Print Preview toolbar and make certain that all buttons display.  At the same time, make certain you know which button is the Office Links button.

· Click the OfficeLinks drop-down menu and select Publish It with Microsoft Word.  Your report will open as a Word document.

· Close all open Object windows.

Compacting and Closing a Database

Compacting databases conserves storage space and memory on your computer.  Access can work with files larger than the available of random access memory (RAM).  This is possible because Access is loading only parts of the file from the disk into RAM.  For this reason, if you are working from a floppy disk, you cannot remove the floppy until properly closing the database.  You should always close all objects to ensure saving them before closing the database.

Access files can use a lot of storage space on your disk.  They retain space of items you delete.  To minimize the amount of storage used by an Access file, you need to compact the file before closing.

· With the database still open, from the Access menu bar, choose Tools > Database Utilities > Compact and Repair Database.
· If the database is closed the previous action will open a dialog box to select the file you wish to compact.  This creates a second copy of the database which is compacted, and requires renaming the file.

· Click the close button to exit Access.
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